1. #1
    Moderator chazus's Avatar
    Join Date
    Nov 2011
    Location
    Las Vegas
    Posts
    10,277

    Mirror Images acting funny since patch?

    I've noticed almost every time now since patch, my mirror images die the moment I summon them. I've seen a few cases where the third one didn't even have time to get a second cast off before death. When I tested it, I didn't see anything wrong, yet I've noticed a number of times they're effectively useless since they didnt almost no damage, and bought me a total of like... 2 seconds. Did I miss something in the patch notes?
    Gaming: Dual Intel Pentium III Coppermine @ 1400mhz + Blue Orb | Asus CUV266-D | GeForce 2 Ti + ZF700-Cu | 1024mb Crucial PC-133 | Whistler Build 2267
    Media: Dual Intel Drake Xeon @ 600mhz | Intel Marlinspike MS440GX | Matrox G440 | 1024mb Crucial PC-133 @ 166mhz | Windows 2000 Pro

    IT'S ALWAYS BEEN WANKERSHIM | Did you mean: Fhqwhgads

  2. #2
    Stood in the Fire 93sika's Avatar
    Join Date
    Oct 2010
    Location
    China, Shanghai (Studying Mandarin!)
    Posts
    387
    Perhaps if you're doing the dailies on the new Isle of Thunder there may be some phasing in the area that (say if you back off and phase into somewhere else though it's been two steps backwards on your screen) it may have caused them to despawn like a death animation would have ? I'm sure it's none of this, but it could be!

    <Signature by wonderful i4ni>

  3. #3
    Moderator Shangalar's Avatar
    Join Date
    Aug 2011
    Location
    Rijeka, Croatia
    Posts
    1,909
    Haven't seen any bug reports yet on the topic, but it smells like s bug, they weren't changed in any way except their frostbolt being buffed.

    You know what a game's code is like. Screw up one thing and something unrelated 200 pages later breaks.

  4. #4
    Moderator chazus's Avatar
    Join Date
    Nov 2011
    Location
    Las Vegas
    Posts
    10,277
    The utterly frustrating part is....It happened several times (not in the Isle of Thunder area). Pop mirror images, and they're dead before my second spell goes off. Yet trying to TEST it. Pulling one mob, checking the damage they do, popping mirror images, seeing damage they take.. They seem to function normally. It's like it's malfunctioning only when I'm not looking. >.> They're supposed to have 10% of mage's health, right?
    Gaming: Dual Intel Pentium III Coppermine @ 1400mhz + Blue Orb | Asus CUV266-D | GeForce 2 Ti + ZF700-Cu | 1024mb Crucial PC-133 | Whistler Build 2267
    Media: Dual Intel Drake Xeon @ 600mhz | Intel Marlinspike MS440GX | Matrox G440 | 1024mb Crucial PC-133 @ 166mhz | Windows 2000 Pro

    IT'S ALWAYS BEEN WANKERSHIM | Did you mean: Fhqwhgads

  5. #5
    Moderator Shangalar's Avatar
    Join Date
    Aug 2011
    Location
    Rijeka, Croatia
    Posts
    1,909
    Yeah and they have a 90% aoe damage reduction like most pets, but they die very very fast when mobs focus them single target, so it's most likely not a bug, you just got a bit confused. No worries, happens often hehe.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •