View Poll Results: Do you have lag/fps/freeze issues on elegon

Voters
111. You may not vote on this poll
  • Yes, i have lag/fps/freeze issues

    50 45.05%
  • No, 100% fine

    61 54.95%
Page 1 of 2
1
2
LastLast
  1. #1

    Elegon issues/lag/computer overheat

    Who else has been having issues with elegon since the past 2 weeks.

    My Graphics cards overheats to crap on this fight now, no idea what blizzard did. My PC runs any other game perfectly fine on max settings and hardly goes over 60 degrees, i raid 25 man no other fight does this.

  2. #2
    Yeah I have issues when doing it on raidfinder. However.. this has always been the case when the raid pops bloodlust and stormlash and you have minimum one army of the dead going out. If that happens (90% of time), I am out until phase 2 channel begins.

  3. #3
    I've done LFR Elegon twice this week and haven't had any issues at all. The final burn phase is very graphically intense, so naturally my FPS drops a little bit, but never lower than 25 or so, compared to my usual 35-50 fps in 25man combat.

  4. #4
    Moderator Kerdoz's Avatar
    Join Date
    Apr 2011
    Location
    Sweden
    Posts
    6,722
    I have never had any issues with Elegon. Sure I get some small FPS drops when fighting him. But it is so small it is not an issue.

  5. #5
    Warchief Akraen's Avatar
    Join Date
    Dec 2011
    Location
    SC, USA
    Posts
    2,126
    No problems:

    AMD FX-8350
    AMD Radeon HD 7970 OC (Sapphire Vapor-X 3gb)
    16gb g.skill Sniper Series 2100mhz

  6. #6
    Guildies just complained about this aswell, getting major fps issues when the fight starts.

  7. #7
    Your fps should not drop during the first couple of phases on elegon. However, during the last phase(after 2x spark phases) when you all stack on him pop Hero stormlash etc etc there have been fps drops since week 1, i imagine it might be all that coupled with the storm going around outside the platform. some have it worse than others, i normally go from 60fps stable to ~30-40fps during last phase. But i got everything on ultra gfx settings, im sure if i turned it down to high it would be no problem.

  8. #8
    High Overlord
    Join Date
    Jul 2011
    Location
    Adelaide
    Posts
    162
    I had issues on Elegon where frame rate dropped to 5 - then froze for a few seconds then back to somewhat normal. It's been happening in the new zones as well. Computer has been overheating and frame rate inconsistency. Very annoying.

  9. #9
    Had this problem in an lfr earlier in the week. Spirit kings and Will I was in the mid 50s for FPS. Elegon I was right about 5 when the central area was active. When it wasn't usual FPS. Really unsure why.

  10. #10
    Its an addon issue.

  11. #11
    had this problem on one of my toons this week, assumed it was an addon not yet properly updated
    i7 2600k (standard clocks)
    7870 card
    8g ram

    again this only happened on the one toon, my warlock in specific so im guessing it was an addon

  12. #12
    Quote Originally Posted by Teye View Post
    Its an addon issue.
    Can anyone please elaborate on this? Just recently my pc went nuts on elegon...
    Quote Originally Posted by Validity View Post
    If rogues become shit, all they can become is a different type of shit.

  13. #13
    There was an issue with Elegon where fps went all to hell when you stood on the platform. It happened particularly with some Radeon video cards. The solution was to turn shadow quality UP to good. Weird, but this cleared it up for me. Primordius also showed the same problem, to a lesser extent (probably because the floor there is simiarly removable.)

    If you are seeing something happening more recently, it may be a different problem.
    "There is a pervasive myth that making content hard will induce players to rise to the occasion. We find the opposite. " -- Ghostcrawler
    "Almost every time I have gotten to know a critic personally, they keep up with the criticism but lose the venom." -- Ghostcrawler

  14. #14
    Quote Originally Posted by pkm View Post
    Can anyone please elaborate on this? Just recently my pc went nuts on elegon...
    Was there really a need to necro this thread? When 5.2 came out lots of addons where still out of date that, combined with increased size of combat log, didn't make the fight easier to run. However running the fight with Shadow Quality on High+ improves performance, just as Osmeric said.

  15. #15
    Quote Originally Posted by Trubo View Post
    Was there really a need to necro this thread? When 5.2 came out lots of addons where still out of date that, combined with increased size of combat log, didn't make the fight easier to run. However running the fight with Shadow Quality on High+ improves performance, just as Osmeric said.
    I am aware of the shadows fix and google came up with this. It just happened all of a sudden but i will check my add ons and see how it goes.
    Quote Originally Posted by Validity View Post
    If rogues become shit, all they can become is a different type of shit.

  16. #16
    Last tier i did heroic elegon with no problems whatsoever on the same laptop, running on ultra settings, and getting around 40-50 FPS in 10 man and in 25 LFR. Ever since the launch of the new patch whenever i do elegon on LFR/Normal/Heroic my fps drops to about 4 or 5 now.

    So i know its nothing to do with my computer at least. They changed something.

    http://www.youtube.com/watch?v=IBmNL...ature=youtu.be (#1 SSB Gold run on Bleeding Hollow)
    "Your lights will go out. The darkness will envelop you. And you will fear the shadows that move within it."

  17. #17
    Quote Originally Posted by Theholypally View Post
    So i know its nothing to do with my computer at least. They changed something.
    Did you try the shadow setting tweak? That fixes the problem introduced in 5.2 for certain graphics chips.
    "There is a pervasive myth that making content hard will induce players to rise to the occasion. We find the opposite. " -- Ghostcrawler
    "Almost every time I have gotten to know a critic personally, they keep up with the criticism but lose the venom." -- Ghostcrawler

  18. #18
    Quote Originally Posted by Osmeric View Post
    Did you try the shadow setting tweak? That fixes the problem introduced in 5.2 for certain graphics chips.
    Forgive me but wouldnt it cause more issues to turn up graphics? currently my shadow settings is on low, and id be glad to try it, but idk just seems odd. Would setting it to 'good' work?

    Ive been having the same issues with primordius' room, and dark animus' room as well with tragic fps drops. The primordius room is an easy fix: stay out of the middle of the room lol. But durumu/primordious/animus rooms all have given me some very annoying play experiences as well.
    Last edited by Theholypally; 2013-08-02 at 01:43 PM.

    http://www.youtube.com/watch?v=IBmNL...ature=youtu.be (#1 SSB Gold run on Bleeding Hollow)
    "Your lights will go out. The darkness will envelop you. And you will fear the shadows that move within it."

  19. #19
    Mechagnome Criiz's Avatar
    Join Date
    Sep 2009
    Location
    United Kingdom
    Posts
    519
    I get lag but apparently if you turn up shadows it fixes the problem, haven't tried it myself like.

  20. #20
    Quote Originally Posted by Theholypally View Post
    Forgive me but wouldnt it cause more issues to turn up graphics? currently my shadow settings is on low, and id be glad to try it, but idk just seems odd. Would setting it to 'good' work?

    Ive been having the same issues with primordius' room, and dark animus' room as well with tragic fps drops. The primordius room is an easy fix: stay out of the middle of the room lol. But durumu/primordious/animus rooms all have given me some very annoying play experiences as well.
    Yes, it doesnt make sense, but turn up your shadow detail. It has worked for many many people. Both elegon's and primo's rooms have floors which disappear, which is the only thing I can fathom which could be the root of the problem. Kinda like how if you die in the middle of primo's room, your skellie takes on a strange bluish color.

    Why elegon's room was fine at release, and now causes these problems is strange tho.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •