1. #1
    The Lightbringer Danishpsycho's Avatar
    Join Date
    Oct 2010
    Location
    Denmark
    Posts
    3,059

    Random FPS Drops

    So since the weekend a guildie of mine started having major FPS spikes/drops out of no where. Today, I got it as well and then this evening 2 or 3 more people got it. Maybe about every 10 seconds or so, my FPS will go from almost 200 to 45 in a split second.

    Was just wondering, if anyone else have the same issue. Seeing that I doubt all of us just starts getting FPS issues more or less at the same time and none of us normally have that happen.

    Haven't seen any Blue Posts about it, but kinda thinking it's something with the game and not our computers.

  2. #2
    The Patient Chisato's Avatar
    Join Date
    Mar 2011
    Location
    Ontario
    Posts
    233
    I've been experiencing the same issue. I don't run many add ons and the memory usage is never high so I'm truly at a loss for what's causing it. I run Nvidia btw

  3. #3
    The Lightbringer Seezer's Avatar
    Join Date
    Aug 2010
    Location
    Capua
    Posts
    3,737
    I'm having the same problem. FPS going down to abysmal rates for the specs I have. My specs are

    -GTX 680
    -i5 3570k
    -16g ram
    -Sabertooth Z77

    This computer is about 3 months old. This is getting old. And on top of that, multisampling in wow is atrocious. In the distance, I always see little white dots on mountains and such.
    "1 in 4 Americans are skeptical on climate change...who gives a shit? That doesn't matter. You don't need other people's opinions on a fact. You may as well have a poll asking: Which number is bigger? 5 or 15? Do Owls exist? Are there hats?"

  4. #4
    I've noticed that some "explosion" type effects such as Frost Nova/Shadowfury type things will cause a momentary drop in FPS. Also certain blue particle effects will slow everything down while they're active.

  5. #5
    The Lightbringer Danishpsycho's Avatar
    Join Date
    Oct 2010
    Location
    Denmark
    Posts
    3,059
    I know that at least one of my guildies and myself are using Nvidia as well but I honestly doubt that would be the reason. One guildie said, that she seems to notice it a lot more, when Smoke Bomb is being used (She's a Rogue) and there was another ability as well.

    Another of my guildies would drop to 1 FPS after dying and being unable to do anything for maybe a minute or so.

    When did you people start having issues?

    Edit: I opened a ticket and hopefully we'll get some sort of clarification and better yet a solution.
    Last edited by Danishpsycho; 2013-06-19 at 09:08 AM.

  6. #6
    Dreadlord vmagik's Avatar
    Join Date
    Dec 2012
    Location
    Acherus
    Posts
    858
    It's possible that a new driver, implemented effect or outdated addon is causing an issue.

    Additionally I'd recommend running with vsync enabled (with triple buffering and, if it feels smoother "reduce input lag") to reduce frame rate spikes.
    Amazing signature courtesy of Shyama

  7. #7
    The Lightbringer Danishpsycho's Avatar
    Join Date
    Oct 2010
    Location
    Denmark
    Posts
    3,059
    I am actually doing that, changed the settings, when the spikes started. The thing is, that the only thing I updated yesterday was the alpha version of DBM. No other updates from add-ons or Windows at all.

  8. #8
    Blizzard Araxom's Avatar
    Join Date
    Jan 2013
    Location
    Irvine, CA
    Posts
    356
    Hi all, if you're running addons - the first thing to try would be to back your addons folder up (rename it/save to desktop) - then go through the reset UI steps. If the framerate continues to be an issue, and none of the steps on this page improve the issue, then I would suggest collecting the system diagnostics and attach those to a ticket for us to review. Hope that helps!

  9. #9
    Old God Winter Blossom's Avatar
    Join Date
    Dec 2010
    Location
    "Winter is coming"
    Posts
    10,051
    Try running it with vsync on and triple buffering. Most people don't even need to have vsync disabled. If you have a 60 hz monitor, you'll only ever see 60 fps, regardless if you're getting 120+ ingame.

    ---------- Post added 2013-06-19 at 02:04 PM ----------

    Do you have Weak Auras or Tidy Plates? I know those can cause some serious fps drops in Raids.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •